Unfortunately due to other commitments, we are no longer able to provide support for these themes.

All our themes are now free and can be downloaded by anyone to use/modify however they wish.

We want to thank all our users for their support over the years. All the best in 2020 and beyond.

Modify thumbnail pictures to square at Themedy Featured Slider

jixiang_wujixiang_wu Lifetime Member
How to modify the thumbnail pictures to square at Themedy Featured Slider of homepage?
The thumbnail pictures just show 4:3 or 3:2, I need 1:1. Please check at www.albhardware.com.au

Comments

  • Options
    matt_hoddermatt_hodder Moderator, Lifetime Member
    You would need to add the following custom css:

    body #featured-slider .slide, body #featured-slider-area .flex-caption { width: 300px; height: 300px; }

    Then you would need to edit the readyfolio2/skin.php file. On line 47, change
    add_image_size('featured-portfolio-slide', 500, 300, TRUE);
    to:
    add_image_size('featured-portfolio-slide', 300, 300, TRUE);

    Download the "Regenerate Thumbnails" plugin and run that to get your new image size.

    If you follow those steps, the slider should be 300 pixels wide and tall.
  • Options
    jixiang_wujixiang_wu Lifetime Member
    Thanks for help, but it seems too complex to modify a slider picture size by a new plugin.
    Why not just modify without plugin.
  • Options
    matt_hoddermatt_hodder Moderator, Lifetime Member
    All the new plugin does is reprocess the WordPress auto-generated thumbnails to the new custom size we defined. You can disable it once you have ran it once (after making the custom code changes I listed before).
  • Options
    jixiang_wujixiang_wu Lifetime Member
    Please help me again, After set a Color Scheme at Readyfolio Skin Design Options.
    The website: https://www.albhardware.com.au/
    has broken with random code.

    There are another website https://www.albhardware.com also have this problem before, and I have changed another skin.

    Please help me. It is VERY urgent.
  • Options
    matt_hoddermatt_hodder Moderator, Lifetime Member
    Log in to your WordPress admin and go to Thesis > Custom CSS.

    Add the following code and hit "Save Custom CSS":
    columns:after, #footer_widgets .wrap:after, .post_box:after, .post_box .post_content:after, .sidebar:after, .sidebar .post_content:after, .menu-primary:after, .comment .comment_text:after, .widget:after, .prev_next:after, .post_box:after, #header:after, #inner:after, #secondary_area:after {
        content: ""; display: block; height: 0; clear: both; visibility: hidden;
    }
    That should fix up the layout issues. You may have to go back to your Skin Design section to save the colour scheme again.
  • Options
    jixiang_wujixiang_wu Lifetime Member
    Thanks for help, I have added the code to custom css, also saved the colour scheme again,
    But the layout issues still not fixed.
    Please check and help again.
    Thanks.
  • Options
    matt_hoddermatt_hodder Moderator, Lifetime Member
    Change the code to this:
    columns:after, #footer_widgets .wrap:after, .post_box:after, .post_box .post_content:after, .sidebar:after, .sidebar .post_content:after, .menu-primary:after, .comment .comment_text:after, .widget:after, .prev_next:after, .post_box:after, #header:after, #inner:after, #secondary_area:after {
        content: ''; display: block; height: 0; clear: both; visibility: hidden;
    }
    and save again.

    It seems a recent Thesis update changed the way they handle some code, breaking a lot of our own. We will release an update soon but for now that code should fix it up.
This discussion has been closed.