Unfortunately due to other commitments, we are no longer able to provide support for these themes.

All our themes are now free and can be downloaded by anyone to use/modify however they wish.

We want to thank all our users for their support over the years. All the best in 2020 and beyond.

Mixed Content Warning on SSL site: Google Fonts

jrichwagenjrichwagen Lifetime Member
Jody Richwagen
Antrimweb Internet Marketing
www.antrimweb.com

Comments

  • Options
    Mark_HodderMark_Hodder Administrator, Lifetime Member
    I'll check into it but the immediate work around would be something like this - I've used it before, it works well: https://en-ca.wordpress.org/plugins/really-simple-ssl/
    Need Additional Help?
    - Check out the Resource Center for helpful tutorials and hints.


    image
  • Options
    jrichwagenjrichwagen Lifetime Member
    Thanks. With Google (Chrome) and the others pushing toward SSL sites, this is something (directing to https://fonts.googleapis.com/...) we need.

    Ironic, it was Google Fonts that is considered insecure :)
    Jody Richwagen
    Antrimweb Internet Marketing
    www.antrimweb.com
  • Options
    Mark_HodderMark_Hodder Administrator, Lifetime Member
    After looking at this more there is really only two options here:

    - Keep using the plugin, assuming that worked.

    - Edit default.php included with the skin and search for the various http://fonts.googleapis.com and replace with https://fonts.googleapis.com. Then go into the Skin Editor -> Data Manager and restore defaults on the "Templates" option only. Obviously don't do this if you have changed / added to the various Grind templates using the Thesis skin editor unless you are prepared to make those changes again as it resets them to the defaults.

    Since the Thesis skin editor doesn't allow partial updates to templates they have to be fully restored for the 2nd option to work.
    Need Additional Help?
    - Check out the Resource Center for helpful tutorials and hints.


    image
  • Options
    jrichwagenjrichwagen Lifetime Member
    edited September 2017
    That is not going to work. These are all existing sites we are transitioning to SSL. I have edited the skin templates. Will note for new sites we are setting up to make this change before editing the skins.

    Have not tried the plug in. If I run into a problem, it looks like we'll have to edit the default.php.

    Why can't Google do what the rest of us are & redirect http://fonts.googleapis.com to httpS://fonts.googleapis.com? Geez!

    Thanks for your help.

    ETA: Is this something DIYTHemes (Thesis) could help with? I can't be the only one encountering this with the sites.
    Post edited by jrichwagen on
    Jody Richwagen
    Antrimweb Internet Marketing
    www.antrimweb.com
  • Options
    Mark_HodderMark_Hodder Administrator, Lifetime Member
    The plugin worked fine on my end so that is your best bet for existing sites - there's nothing wrong with using it to fix this, I use it all the time. As a bonus it'll fix any other random plugin issue or other things that may break your SSL now or in the future anyway.

    For new sites start with Grind 1.3 and you won't need to make any changes. However, on existing sites you can't actually pull any changes made in default.php file unless you use the restore button in the skin editor so that's why that step is necessary to go that route - since that's just the core of how Thesis works in general.
    Need Additional Help?
    - Check out the Resource Center for helpful tutorials and hints.


    image
  • Options
    jrichwagenjrichwagen Lifetime Member
    Thank you for your help. The Really Simple SSL plug in seems to have fixed the problem with Google Fonts.
    Jody Richwagen
    Antrimweb Internet Marketing
    www.antrimweb.com
This discussion has been closed.