Unfortunately due to other commitments, we are no longer able to provide support for these themes.

All our themes are now free and can be downloaded by anyone to use/modify however they wish.

We want to thank all our users for their support over the years. All the best in 2020 and beyond.

Mixed content warning re: header image in SSL

I have an issue with the secure SSL version of my site. It appears that the header image URL is stuck on http:// instead of changing when the protocol switches to https://, which in turn is triggering mixed-content warnings that might be off-putting to purchasers.

Is there some way to have the URL of the header image be set to // instead of http://, or just make it a relative path? I even tried editing the path in the database itself, but that only made the image disappear altogether. According to the Network panel in Chrome, this one header image is the only mixed content, so fixing it should clear up the problem.

thanks,
Bill Womack

Comments

  • Options
    Mark_HodderMark_Hodder Administrator, Lifetime Member
    Hi Bill, I don't think we do anything in regards to the header other then hook into the built in Thesis 2 function. Maybe if you uploaded it when on the http version of the site it might fix it to delete it and reupload it if you haven't tried that.

    I personally just install and activate this great plugin and it takes care of any current and potentional future issues: https://en-ca.wordpress.org/plugins/really-simple-ssl/
    Need Additional Help?
    - Check out the Resource Center for helpful tutorials and hints.


    image
This discussion has been closed.