Unfortunately due to other commitments, we are no longer able to provide support for these themes.

All our themes are now free and can be downloaded by anyone to use/modify however they wish.

We want to thank all our users for their support over the years. All the best in 2020 and beyond.

Variable products and shipping no longer working

oliesclosetoliescloset Fremedy, Clip Cart, Tote
I spent the past few days trying to fix a pagination problem, and couldn't remember how I fixed it on another site 2 years ago.

I (too late) found my question posted 2 years ago regarding the pagination issue and fixed it, but now my site is really screwed up :(
I thought it was a 'Thesis' problem and spent a couple days trying to get assistance in diy. I just couldn't recall how the problem was resolved 2 years ago until this morning when I finally remembered it was ClipCart and found the answer in my old post.

Apparently I screwed something up big time as this morning I found that all of my woocommerce 'variable' products have reverted to 'simple'. Even adding a new product the same thing happens.

To add insult to injury, shipping is no longer working either.

I figured it was a 'woocommerce' issue so I went ahead and updated to their new version with the hopes it would be fixed. Well, it wasn't.

So I ended up removing the new version of woocommerce and uploaded the previous version via ftp.

I am now back to square one in that none of my products will save as variable, and shipping calculation is also not working during checkout and have the previous version of Woocommerce installed v 2.5.5

I posted a question to woo themes and Mike Jolly replied:
"You need to establish if one of your plugins or theme is removing the 'variable' type or preventing save. WC has no mechanism to change product types by itself."

I haven't changed nor updated or loaded any new plugins the past several days with the exception of what I did with Woocommerce as stated above.

Is there a way to uninstall and reinstall ClipCart? Would this fix the problem?

Please, does anyone know how to fix this? I have been going through one financial crisis after another the past 6 months, and this new site was looking to be a lifesaver for me. Now I can't generate any income from it.

Something's broken, and I don't know how to fix it :( I would prefer not having to begin from scratch all over again. It took me 2 months to get the site to where it is (or was, lolol)

Is there a way to reinstall Thesis and Clipcart without also removing all my Woocommerce stuff and losing everything?

And yeah... financially I wasn't able to renew my license for Backup Buddy and ALSO didn't figure out how to install the version I have on my other site until this afternoon :( So stupid, stupid...no backup to restore to ...

Please help, someone .....

Comments

  • Options
    oliesclosetoliescloset Fremedy, Clip Cart, Tote
    Okay.... IS there a way to reinstall Thesis and ClipCart WITHOUT losing all my woocommerce products, info , etc?

    Can I just deactivate all my plugins, then delete Thesis and ClipCart, then reinstall them?

    I have downloaded my sql database, have Backup buddy installed now (too late for what I need it for right now though), and I have downloaded a backup of my Skin Data.

    So how do I do this properly without having to build everything from scratch all over again?
    Could someone pleassssssssssssseeeee answer?? Thanks...
  • Options
    Mark_HodderMark_Hodder Administrator, Lifetime Member
    You should first contact your webhost support as they generally also have backups that they may be able to restore for you - even if they don't advertise this.

    Clip Cart doesn't touch anything in the WooCommerce database, so it couldn't of done that to your products - I can't see how Thesis would have either to be honest. I just tried creating a variable product with the latest version of Clip Cart / Thesis 2 / WooCommerce and it seemed to save fine on my end.

    "Can I just deactivate all my plugins, then delete Thesis and ClipCart, then reinstall them?"

    Yes, like I mentioned above Clip Cart and Thesis really have no connection into WooCommerce, so deactivating / deleting them isn't going to touch your WooCommerce data. Plugins I can't speak to as I don't know what you are using - but they shouldn't.

    All the same make sure you have a complete backup of your site before doing this - not just the SQL database - the whole WordPress install including files in case things go any worse.

    It's much more likely this is a plugin conflict, deactivate all your plugins except for WooCommerce and test to see if you can save a variable product, if you can enable them back one by one until it breaks and then that tells you which plugin is the source of the issue.

    If none of this helps you can use the link in my signature to hire us to try and figure out this for you as well. Hopefully something above gets it fixed though.
    Need Additional Help?
    - Check out the Resource Center for helpful tutorials and hints.


    image
  • Options
    oliesclosetoliescloset Fremedy, Clip Cart, Tote
    Okay, I will try what you suggested. It's so weird because everything was working fine, and now it doesn't :(
  • Options
    oliesclosetoliescloset Fremedy, Clip Cart, Tote
    Well, I just deactivated a bunch of plugins AND I DID find that it's the NSP Code Plugin - Advanced Taxonomy Terms Order & Plugin -Post Types Order.... I now seem to recall that I updated them a day or so ago... I dunno, but that's the problem. I contacted them and hopefully they can resolve the issue as it's a sweet plugin that I rely on greatly.

    Thanks for your help and advice Mark! I appreciate it very much :)
  • Options
    Mark_HodderMark_Hodder Administrator, Lifetime Member
    Great to hear, hope they get it sorted!
    Need Additional Help?
    - Check out the Resource Center for helpful tutorials and hints.


    image
  • Options
    oliesclosetoliescloset Fremedy, Clip Cart, Tote
    They contacted me this morning for a wp login so they can take a look. They took a look at a problem with their plug-in on my other site a few months ago and fixed the issue. I hope they can fix the current issue as their plug-in is a really important one. I've never had their plugin 'break' my site before, just functioning issues within the plugin's tasks. The only difference between the 2 sites in terms of theme, skin, etc. is the new site with the current problem is using the latest version of Thesis and I think a more recent version of WP (I can't recall for sure right now, but I believe so).

    When you have lots of products and lots of product variations, sorting properly & logically according to product name and type becomes an essential function. WP is a royal pain in regards to sorting and is most often 'adamantly stuck' on posting according to 'time'. I suppose there are still some very hardcore blog tendencies embedded in WP even after all these years.

    I wish advanced sorting capabilities was built into the skin so I wouldn't need to use a plugin at all. Is that even possible?

    Once again, thanks for helping me and providing me with the info I needed to make the best decisions regarding how to identify and rectify the problem.
This discussion has been closed.